Technical Requirements for Video at UF Law

UF Law is proud to have an ever increasing video presence online. Below are some technical requirements for different formats that we use.

Last Updated: February 20, 2013

Mediasite Technical Requirements

**Please note that live streaming is not available for iOS devices such as an iPad or iPhone.  Playback, however, does work on iOS devices.**

If you are having technical issues, the UF Help Desk is available at (352) 392-4357 to troubleshoot any issues with the computer.

For more information about the Mediasite Player, click here.

Before you begin, here are some things to consider:

Windows requirements

  • Microsoft Windows 7, Windows Vista, Windows XP, Windows 2003
  • Microsoft Internet Explorer® 7.0 or later, Firefox® 3.6 or later, or Google™ Chrome (Internet Explorer Preferred)
  • Microsoft Silverlight® 5.0 plugin
  • Broadband Internet connection (recommended)

Mac requirements

  • Apple Mac OS X 10.4.8 or later
  • Apple Safari™ 2.0.4 or later or Firefox 3.6 or later
  • Microsoft Silverlight 5.0 plugin
  • Broadband Internet connection (recommended)

iPad requirements (on-demand playback only)*

  • iPad, iPad2, or iPad3
  • iOS 4.3 or later
  • Apple Mobile Safari™
  • Wi-Fi or cellular data connection (3G or higher)

iPhone/iPod requirements (on-demand playback only)*

  • iPhone 4.0 or later, iPod Touch 4th generation or later
  • iOS 4.3 or later
  • Apple Mobile Safari
  • Mediasite iPhone/iPod app (free download available from the Apple app store)
  • Wi-Fi connection

Linux requirements

  • SUSE® Linux Enterprise Desktop 10, openSUSE® 11.0 or later, Ubuntu® 8.04, or Fedora® Core 9
  • Firefox 2.0 or 3.0 depending on Linux operating system
  • Moonlight™1.0. Moonlight 1.0 supports the operating systems and platforms listed here.
  • Microsoft Media Pack for Moonlight
  • Broadband Internet connection

Notes:

  • Moonlight is an open source implementation of Microsoft Silverlight for Unix systems. For more information about Moonlight go here.
  • Mediasite will no longer support playback of Windows Media Format on the Linux platform. Instead, Mediasite will support on-demand presentation playback of H.264 content packaged as MP4. You will need to install the codecs required for H.264 content playback. In addition, you must use a browser that supports H.264 codecs with the HTML5 media element. For more information, go here.

Blackberry requirements (on-demand playback only)*

  • Blackberry devices running Blackberry OS 7.0 or later
  • Playbooks devices running QNX
  • Blackberry browser
  • Wi-Fi or cellular data connection (3G or higher)

Android requirements (on-demand playback only)*

  • Android™ 4.0 or later
  • Android browser
  • Wi-Fi or cellular data connection (3G or higher)

Additional considerations

To view Mediasite presentations using Firefox over Windows Vista or Windows XP:

  • Use the ActiveX Plug-in you are prompted to download when you first attempt to view a presentation.
    OR
  • Copy the Windows XP plug-in dlls to your machine following these instructions.

If you are having problems and your computer meets the system requirements, visit Sonic Foundry’s Troubleshooting Mediasite Playback web resource for tips on troubleshooting your computer and more information on Player features.

* Items with an asterisk indicate that the video will not work as a live stream on these devices.

UF Logo
© 2014 University of Florida Levin College of Law, 309 Village Drive Gainesville, FL 32611
Make a gift
Text Only Options

Top of page


Text Only Options

Open the original version of this page.

Usablenet Assistive is a UsableNet product. Usablenet Assistive Main Page.